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Dental Terminology 
Pharmacology 
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Home Health Aide
Foundations of HOSA 

Bowl

Nursing Assisting 
Vet Science

CPR/First Aid
CERT Skills
ATC Tests

Medical Math

TEST PLAN 
CHANGES



Health Science 
Events



CULTURAL DIVERSITIES AND 
DISPARITIES

●Name change to: “World Health and 
Disparities” 

● Reflects the international organization 
better

●Competitors will gain knowledge on world 
health disparities and how to overcome 
them



Recognition 
Events



AMERICAN RED CROSS VOLUNTEER 
RECOGNITION EVENT

●Change in the logistics of tracking
● Using internal HATS for consistency 

purposes



Emotional Well-Being Challenge

●Teams must register for ILC to be 
recognized
○ Different from recognition events like 

Barbara James Service Award (no ILC 
registration required, HATS required)



Health 
Professions 

Events



Dental Science
○ RETIRE  the current text, Dental 

Assisting:  A Comprehensive Approach
○ ADD Modern Dental Assisting 14th 

edition by Debbie S. Robinson
○ add DHO: Health Science by Simmers 

for skills only
○ Updates to skills and test plan to align 

to new books



Phlebotomy

●Adding Skill IIIB - Venipuncture Using a Butterfly and 
Evacuated Tube Adaptor



Emergency 
Preparedness



CERT Skills 
● Triage is back!
● Added 2 resources to align this new added skill
○ using SALT: https://www.ndlsf.org/salt
○ and FAST (First Aid for Severe Trauma) through the 

American Red Cross
○ https://www.redcross.org/take-a-class/first-

aid/first-aid-training/first-aid-classes/fast-training

https://www.ndlsf.org/salt
https://www.redcross.org/take-a-class/first-aid/first-aid-training/first-aid-classes/fast-training
https://www.redcross.org/take-a-class/first-aid/first-aid-training/first-aid-classes/fast-training


EMT

●Skills for administering Naloxone have been updated to 
reflect EMT practice.

●NAEMT support



Public Health

●Round 1 has moved from an in-person presentation to a 
video submission (pre-judged for ILC) 
○ Still “trailer” style approach
○ Convince judges to see full round 2 presentation

● Display Time is now required for ILC
○ Bring electronic devices and showcase videos to 

conference attendees



Leadership 
Events



Healthy Living

●Supported by a new event sponsor
●All new resources
●Provided to you online in a “course” style 

format for easy access and navigate as you 
prepare for the test



Teamwork 
Events



Health Career Display, Exploring 
Medical Innovation,  Medical Innovation

●Digital round 1 submission instead of in-
person round 1

●Outline of key content  / “the plan” for the 
display board and exhibit

●Narrative explaining creative plan
●PPT slide type of format for submission



NEW Events



NEW 
EVENTS!Patient Care Technician



NEW 
EVENTS!

Environmental 
Health 

(ATC Test)



NEW 
EVENTS!

Occupational Therapy
Resources:
● Introduction to Occupational Therapy by O’Brien & Conners
● Conditions in Occupational Therapy by Atchison & Dirette.

Test plan:
● Profession of OT 

10%
● Occupational Therapy Models of Practice 

10%
● Activity Analysis and Occupation-based Activities 10%
● Occupational Therapy for Physical Conditions 

20%
● Occupational Therapy for Wellness and Mental Health 20%
● Ethical and Safety Considerations

10%
● Occupational Therapy Across the Lifespan 

20%
● Children

Adults

https://www.amazon.com/Introduction-Occupational-Therapy-Clifford-MS-ED-L/dp/032379856X/ref=sr_1_1?crid=3B52DORH5K3XR&dib=eyJ2IjoiMSJ9.Heg9y985zAzm2vghjouqEyjcBjksVsueVM6VEg9uu-0gFlfM33FmcvXWYtg0KLfTM2fy9I38kTi1psReA_HZZdmRC7IqJkFDTACc1pAMud-Rnbnz--7Diq7WT6tBy9z8Ng8sTsXOZD653wPO0uBmeN85Xjv0UzCmiXYe18dRAEaaeXxykrStzrvq5U066KBZww53uc7PiIPObigj6FUC-yR0tlLkTDM0hASTvqbrFo4.Vre8GEWEox2cvW5eVXBjopawDAb46fhKrlAofc8faKc&dib_tag=se&keywords=introduction+to+occupational+therapy&qid=1717677264&sprefix=introductgion+to+occupation+therapy+%2Caps%2C123&sr=8-1
https://www.amazon.com/Conditions-Occupational-Therapy-Performance-Lippincott/dp/1975209354/ref=sr_1_1_sspa?crid=276RFH356FRK2&dib=eyJ2IjoiMSJ9.yIaGpJnQUHSsDGcLhohx_7PZjRO1wuw9hJ87_jI7vWr8szc9LS7d80iMvUXdQtsNV0yCUkBdz2U0hqWkMK-Tj1NqHqe_mBM44tVvb4gilVRT610u9DBbbfHi6pZuqjH1BuP_njYcf6u5rlVGLE2RZb7exAnmmzY1MWGSNUICzJUKLbE3Wp3XYUX-c5Ba4eEJjtNPnhWZV7ZQKAbzG8MXSiJm-AOGKgIMBJ3HBg6enRw.cbrUEhkywVPu321JNEvYcKAajwTJc76dGX3VhL7mPUg&dib_tag=se&keywords=Conditions+in+Occupational+Therapy&qid=1717677309&sprefix=conditions+in+occupational+therapy%2Caps%2C119&sr=8-1-spons&sp_csd=d2lkZ2V0TmFtZT1zcF9hdGY&psc=1


NEW 
EVENTS!

Health Literacy Ambassador
● New Recognition Event
● Sponsored by the National Library of Medicine
● Highlights importance of finding quality health 

information online
“Health misinformation is a serious threat                                  
to public health. It can cause confusion, sow             
mistrust, harm people’s health, and                            
undermine public health efforts.”



Annual 
Books and 

Topics



Medical Reading Books
Middle School



Medical Reading Books

Postsecondary/Collegiate and Secondary Divisions



ANNUAL 
TOPIC!

Biomedical Debate:

The government should regulate social media use 
for people under age 18.



ANNUAL 
TOPIC!

Researched Persuasive Writing and 
Speaking:

Should GLP-1 agonists have open access for 
anyone who wishes to use it?



ANNUAL 
TOPIC!

Public Health:
Our Epidemic of Loneliness and Isolation:
Social Disconnection - A Public Health Concern 



ANNUAL 
TOPIC!

Public Service Announcement:
Brain Health - Now is the Time to Start



ANNUAL 
TOPIC!

Speaking Skills and Prepared Speaking:

Powered by People



Texas HOSA 
Updates



November 11, 2024 Online Testing Reg Site Open
November 25, 2024 Online Testing Reg Deadline
December 2, 2024 Online Testing Reg  Fees Due
December 10-12, 2024 Online Testing
December 13, 2024 Online Testing Results Posted

Online Testing

Calendar of 
Events

November 15, 2024 Affiliation Deadline for SS
February 1, 2025 Affiliation Deadline for PS/MS/Collegiate

September 2, 2024 Fall Conference Reg Site Open
December 16, 2024 Spring Conference Reg Site Open

Conference Sites

Affiliation


YearlyCalendar

		School Year Calendar Template

		https://www.vertex42.com/calendars/school-calendar.html																																																										© 2013-2018 Vertex42 LLC				INSTRUCTIONS



						Year:		2024														Beginning Month:		7																								Start day:		1		 1:Sunday, 2:Monday												«  Choose the year and beginning month

																																																																Note: If you choose Monday as the start day, you will need to modify some of the formatting in the calendars (bold vs. non-bold days).



				TEXAS HOSA



				2024-2025



				CALENDAR OF EVENTS



				July 2024																Affiliation														Area 4												January 2025

				S		M		T		W		T		F		S				November 15, 2024										Affiliation Deadline for SS				September 16, 2024								FLC Reg Deadline				S		M		T		W		T		F		S						Publishing your calendar. If you want to publish a school calendar, you must ensure that it includes the following note and URL in the footer: Calendar Templates by Vertex42.com - https://www.vertex42.com/calendars/school-calendar.html

						1		2		3		4		5		6				February 1, 2025										Affiliation Deadline for PS/MS/Collegiate				September 25, 2024								FLC Fees Due										1		2		3		4

				7		8		9		10		11		12		13																		October 26, 2024								FLC Bel Air HS				5		6		7		8		9		10		11

				14		15		16		17		18		19		20				Conference Sites														February 10, 2025								SLC Reg & Digital Upload Deadline				12		13		14		15		16		17		18

				21		22		23		24		25		26		27				September 2, 2024										Fall Conference Reg Site Open				February 18, 2025								Round 2 Appointments Posted				19		20		21		22		23		24		25

				28		29		30		31										December 16, 2024										Spring Conference Reg Site Open				February 26, 2025								SLC Fees Due				26		27		28		29		30		31								Converting the calendar to a PDF. To publish a school calendar on your website, you should first convert it to a PDF. The best way to do that is to either print to a PDF driver, or in Excel 2010/2013 you can go to Save As and select PDF.

																																		February 28 - March 1, 2025								Conference @ Socorro HS in El Paso																

																				Online Testing

				August 2024																November 11, 2024										Online Testing Reg Site Open				Area 5												February 2025

				S		M		T		W		T		F		S				November 25, 2024										Online Testing Reg Deadline				October 7, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

												1		2		3				December 2, 2024										Online Testing Reg  Fees Due				October 16, 2024								FLC Fees Due																1

				4		5		6		7		8		9		10				December 10-12, 2024										Online Testing				October 19, 2024								FLC Copperas Cove HS				2		3		4		5		6		7		8						Changing the color scheme. You can change the color scheme by going to Page Layout > Themes > Colors.

				11		12		13		14		15		16		17				December 13, 2024										Online Testing Results Posted				January 6, 2025								SLC Reg  & Digital Upload Deadline				9		10		11		12		13		14		15

				18		19		20		21		22		23		24																		January 14, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				25		26		27		28		29		30		31				Area 1														January 15, 2025								SLC Fees Due				23		24		25		26		27		28								Overwriting formulas. You can overwrite a formula to place an "H" in place of a holiday for example. Be very careful if you copy/paste days so that you don't mess up the formulas. You can copy/paste the formulas for the days within the same month, but not between months.

																				October 14, 2024										FLC Reg Deadline				January 17-18,2025								Conference @ Ben Barber Innovation in Mansfield																

																				October 23, 2024										FLC Fees Due

				September 2024																October 26, 2024										FLC Round Rock ISD				Area 6												March 2025

				S		M		T		W		T		F		S				January 20, 2025										SLC Reg & Digital Upload Deadline												FLC Reg Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7				January 28, 2025										Round 2 Appointments Posted												FLC Fees Due																1

				8		9		10		11		12		13		14				January 5, 2025										SLC Fees Due												FLC Channelview HS				2		3		4		5		6		7		8						View the Print Area. To view the current print area, first view the Print Preview (Ctrl+P) then return to the Home tab. Or, go to View > Page Break Preview. The print area will become highlighted with a dashed line. To choose a new print area, select the cells you want to include and go to Page Layout > Print Area > Set Print Area.

				15		16		17		18		19		20		21				February 7-8, 2025										Conference @ Steele HS in San Antonio				January 13, 2025								SLC Reg & Digital Upload Deadline				9		10		11		12		13		14		15

				22		23		24		25		26		27		28																		January 21, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				29		30														Area 2														January 26, 2025								SLC Fees Due				23		24		25		26		27		28		29

																				September 23, 2024										FLC Reg Deadline				January 31 - February 1, 2025								Conference @ Nimitz HS in Houston				30		31										

																				October 2, 2024										FLC Fees Due

				October 2024																October 5, 2024										FLC Clear Brook HS				Area 7												April 2025

				S		M		T		W		T		F		S				January 6, 2025										SLC Reg  & Digital Upload Deadline				October 14, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

								1		2		3		4		5				January 14, 2025										Round 2 Appointments Posted				October 23, 2024								FLC Fees Due								1		2		3		4		5

				6		7		8		9		10		11		12				January 22, 2025										SLC Fees Due				October 26, 2024								FLC Academy of HS Professions La Joya		Sep		6		7		8		9		10		11		12						«  Make a list of important dates. Enter dates as text by entering an apostrophe before the date, like 'Aug 8

				13		14		15		16		17		18		19				January 24-25, 2025										Conference @ Clear Brook HS in Friendswood				January 27, 2025								SLC Reg  & Digital Upload Deadline				13		14		15		16		17		18		19

				20		21		22		23		24		25		26																		February 4, 2025								Round 2 Appointments Posted				20		21		22		23		24		25		26

				27		28		29		30		31								Area 3														February 12, 2025								SLC Fees Due				27		28		29		30						

																				October 14, 2024										FLC Reg Deadline				February 14-15, 2025								Conference @ Mary Caroll HS in Corpus Christi																

																				October 23, 2024										FLC Fees Due

				November 2024																October 26, 2024										FLC Vanguard HS				State												May 2025

				S		M		T		W		T		F		S				February 3, 2025										SLC Reg & Digital Upload Deadline				March 3, 2025								State Registration Opens				S		M		T		W		T		F		S

														1		2				February 11, 2025										Round 2 Appointments Posted				March 24, 2025								Registration & Digital Upload Deadline												1		2		3

				3		4		5		6		7		8		9				February 19, 2025										SLC Fees Due				April 1, 2025								Round 2 Appointments Posted				4		5		6		7		8		9		10

				10		11		12		13		14		15		16				February 21-22, 2025										Conference @ Tyler HS in Tyler				April 4, 2025								Fees Due				11		12		13		14		15		16		17

				17		18		19		20		21		22		23																		April 14, 2025								Early Bird Check-in				18		19		20		21		22		23		24

				24		25		26		27		28		29		30																		April 15-18, 2025						Kalahari Resorts						25		26		27		28		29		30		31

																																																										

																																		ILC

				December 2024																																						Registration Opens				June 2025

				S		M		T		W		T		F		S																										Registration & Digital Upload Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7						Online Testing																				Fees Due				1		2		3		4		5		6		7

				8		9		10		11		12		13		14						FLC-Fall Leadership Conference												June 18-21, 2025								Gaylord Hotel and Convention in Nashville, TN				8		9		10		11		12		13		14

				15		16		17		18		19		20		21						SLC-Spring Leadership Conference																								15		16		17		18		19		20		21

				22		23		24		25		26		27		28						State Leadership Conference 																								22		23		24		25		26		27		28

				29		30		31														ILC-International Leadership Conference																								29		30										
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Area 1 

October 14, 2024 FLC Reg Deadline
October 23, 2024 FLC Fees Due
October 26, 2024 FLC Round Rock ISD
January 20, 2025 SLC Reg & Digital Upload Deadline
January 28, 2025 Round 2 Appointments Posted
January 5, 2025 SLC Fees Due
February 7-8, 2025 Conference @ Steele HS in San Antonio

Area 1


YearlyCalendar

		School Year Calendar Template

		https://www.vertex42.com/calendars/school-calendar.html																																																										© 2013-2018 Vertex42 LLC				INSTRUCTIONS



						Year:		2024														Beginning Month:		7																								Start day:		1		 1:Sunday, 2:Monday												«  Choose the year and beginning month

																																																																Note: If you choose Monday as the start day, you will need to modify some of the formatting in the calendars (bold vs. non-bold days).



				TEXAS HOSA



				2024-2025



				CALENDAR OF EVENTS



				July 2024																Affiliation														Area 4												January 2025

				S		M		T		W		T		F		S				November 15, 2024										Affiliation Deadline for SS				September 16, 2024								FLC Reg Deadline				S		M		T		W		T		F		S						Publishing your calendar. If you want to publish a school calendar, you must ensure that it includes the following note and URL in the footer: Calendar Templates by Vertex42.com - https://www.vertex42.com/calendars/school-calendar.html

						1		2		3		4		5		6				February 1, 2025										Affiliation Deadline for PS/MS/Collegiate				September 25, 2024								FLC Fees Due										1		2		3		4

				7		8		9		10		11		12		13																		October 26, 2024								FLC Bel Air HS				5		6		7		8		9		10		11

				14		15		16		17		18		19		20				Conference Sites														February 10, 2025								SLC Reg & Digital Upload Deadline				12		13		14		15		16		17		18

				21		22		23		24		25		26		27				September 2, 2024										Fall Conference Reg Site Open				February 18, 2025								Round 2 Appointments Posted				19		20		21		22		23		24		25

				28		29		30		31										December 16, 2024										Spring Conference Reg Site Open				February 26, 2025								SLC Fees Due				26		27		28		29		30		31								Converting the calendar to a PDF. To publish a school calendar on your website, you should first convert it to a PDF. The best way to do that is to either print to a PDF driver, or in Excel 2010/2013 you can go to Save As and select PDF.

																																		February 28 - March 1, 2025								Conference @ Socorro HS in El Paso																

																				Online Testing

				August 2024																November 11, 2024										Online Testing Reg Site Open				Area 5												February 2025

				S		M		T		W		T		F		S				November 25, 2024										Online Testing Reg Deadline				October 7, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

												1		2		3				December 2, 2024										Online Testing Reg  Fees Due				October 16, 2024								FLC Fees Due																1

				4		5		6		7		8		9		10				December 10-12, 2024										Online Testing				October 19, 2024								FLC Copperas Cove HS				2		3		4		5		6		7		8						Changing the color scheme. You can change the color scheme by going to Page Layout > Themes > Colors.

				11		12		13		14		15		16		17				December 13, 2024										Online Testing Results Posted				January 6, 2025								SLC Reg  & Digital Upload Deadline				9		10		11		12		13		14		15

				18		19		20		21		22		23		24																		January 14, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				25		26		27		28		29		30		31				Area 1														January 15, 2025								SLC Fees Due				23		24		25		26		27		28								Overwriting formulas. You can overwrite a formula to place an "H" in place of a holiday for example. Be very careful if you copy/paste days so that you don't mess up the formulas. You can copy/paste the formulas for the days within the same month, but not between months.

																				October 14, 2024										FLC Reg Deadline				January 17-18,2025								Conference @ Ben Barber Innovation in Mansfield																

																				October 23, 2024										FLC Fees Due

				September 2024																October 26, 2024										FLC Round Rock ISD				Area 6												March 2025

				S		M		T		W		T		F		S				January 20, 2025										SLC Reg & Digital Upload Deadline												FLC Reg Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7				January 28, 2025										Round 2 Appointments Posted												FLC Fees Due																1

				8		9		10		11		12		13		14				January 5, 2025										SLC Fees Due												FLC Channelview HS				2		3		4		5		6		7		8						View the Print Area. To view the current print area, first view the Print Preview (Ctrl+P) then return to the Home tab. Or, go to View > Page Break Preview. The print area will become highlighted with a dashed line. To choose a new print area, select the cells you want to include and go to Page Layout > Print Area > Set Print Area.

				15		16		17		18		19		20		21				February 7-8, 2025										Conference @ Steele HS in San Antonio				January 13, 2025								SLC Reg & Digital Upload Deadline				9		10		11		12		13		14		15

				22		23		24		25		26		27		28																		January 21, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				29		30														Area 2														January 26, 2025								SLC Fees Due				23		24		25		26		27		28		29

																				September 23, 2024										FLC Reg Deadline				January 31 - February 1, 2025								Conference @ Nimitz HS in Houston				30		31										

																				October 2, 2024										FLC Fees Due

				October 2024																October 5, 2024										FLC Clear Brook HS				Area 7												April 2025

				S		M		T		W		T		F		S				January 6, 2025										SLC Reg  & Digital Upload Deadline				October 14, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

								1		2		3		4		5				January 14, 2025										Round 2 Appointments Posted				October 23, 2024								FLC Fees Due								1		2		3		4		5

				6		7		8		9		10		11		12				January 22, 2025										SLC Fees Due				October 26, 2024								FLC Academy of HS Professions La Joya		Sep		6		7		8		9		10		11		12						«  Make a list of important dates. Enter dates as text by entering an apostrophe before the date, like 'Aug 8

				13		14		15		16		17		18		19				January 24-25, 2025										Conference @ Clear Brook HS in Friendswood				January 27, 2025								SLC Reg  & Digital Upload Deadline				13		14		15		16		17		18		19

				20		21		22		23		24		25		26																		February 4, 2025								Round 2 Appointments Posted				20		21		22		23		24		25		26

				27		28		29		30		31								Area 3														February 12, 2025								SLC Fees Due				27		28		29		30						

																				October 14, 2024										FLC Reg Deadline				February 14-15, 2025								Conference @ Mary Caroll HS in Corpus Christi																

																				October 23, 2024										FLC Fees Due

				November 2024																October 26, 2024										FLC Vanguard HS				State												May 2025

				S		M		T		W		T		F		S				February 3, 2025										SLC Reg & Digital Upload Deadline				March 3, 2025								State Registration Opens				S		M		T		W		T		F		S

														1		2				February 11, 2025										Round 2 Appointments Posted				March 24, 2025								Registration & Digital Upload Deadline												1		2		3

				3		4		5		6		7		8		9				February 19, 2025										SLC Fees Due				April 1, 2025								Round 2 Appointments Posted				4		5		6		7		8		9		10

				10		11		12		13		14		15		16				February 21-22, 2025										Conference @ Tyler HS in Tyler				April 4, 2025								Fees Due				11		12		13		14		15		16		17

				17		18		19		20		21		22		23																		April 14, 2025								Early Bird Check-in				18		19		20		21		22		23		24

				24		25		26		27		28		29		30																		April 15-18, 2025						Kalahari Resorts						25		26		27		28		29		30		31

																																																										

																																		ILC

				December 2024																																						Registration Opens				June 2025

				S		M		T		W		T		F		S																										Registration & Digital Upload Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7						Online Testing																				Fees Due				1		2		3		4		5		6		7

				8		9		10		11		12		13		14						FLC-Fall Leadership Conference												June 18-21, 2025								Gaylord Hotel and Convention in Nashville, TN				8		9		10		11		12		13		14

				15		16		17		18		19		20		21						SLC-Spring Leadership Conference																								15		16		17		18		19		20		21

				22		23		24		25		26		27		28						State Leadership Conference 																								22		23		24		25		26		27		28

				29		30		31														ILC-International Leadership Conference																								29		30										
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Area 2 

September 23, 2024 FLC Reg Deadline
October 2, 2024 FLC Fees Due
October 5, 2024 FLC Clear Brook HS
January 6, 2025 SLC Reg  & Digital Upload Deadline
January 14, 2025 Round 2 Appointments Posted
January 22, 2025 SLC Fees Due
January 24-25, 2025 Conference @ Clear Brook HS in Friendswood

Area 2


YearlyCalendar

		School Year Calendar Template

		https://www.vertex42.com/calendars/school-calendar.html																																																										© 2013-2018 Vertex42 LLC				INSTRUCTIONS



						Year:		2024														Beginning Month:		7																								Start day:		1		 1:Sunday, 2:Monday												«  Choose the year and beginning month

																																																																Note: If you choose Monday as the start day, you will need to modify some of the formatting in the calendars (bold vs. non-bold days).



				TEXAS HOSA



				2024-2025



				CALENDAR OF EVENTS



				July 2024																Affiliation														Area 4												January 2025

				S		M		T		W		T		F		S				November 15, 2024										Affiliation Deadline for SS				September 16, 2024								FLC Reg Deadline				S		M		T		W		T		F		S						Publishing your calendar. If you want to publish a school calendar, you must ensure that it includes the following note and URL in the footer: Calendar Templates by Vertex42.com - https://www.vertex42.com/calendars/school-calendar.html

						1		2		3		4		5		6				February 1, 2025										Affiliation Deadline for PS/MS/Collegiate				September 25, 2024								FLC Fees Due										1		2		3		4

				7		8		9		10		11		12		13																		October 26, 2024								FLC Bel Air HS				5		6		7		8		9		10		11

				14		15		16		17		18		19		20				Conference Sites														February 10, 2025								SLC Reg & Digital Upload Deadline				12		13		14		15		16		17		18

				21		22		23		24		25		26		27				September 2, 2024										Fall Conference Reg Site Open				February 18, 2025								Round 2 Appointments Posted				19		20		21		22		23		24		25

				28		29		30		31										December 16, 2024										Spring Conference Reg Site Open				February 26, 2025								SLC Fees Due				26		27		28		29		30		31								Converting the calendar to a PDF. To publish a school calendar on your website, you should first convert it to a PDF. The best way to do that is to either print to a PDF driver, or in Excel 2010/2013 you can go to Save As and select PDF.

																																		February 28 - March 1, 2025								Conference @ Socorro HS in El Paso																

																				Online Testing

				August 2024																November 11, 2024										Online Testing Reg Site Open				Area 5												February 2025

				S		M		T		W		T		F		S				November 25, 2024										Online Testing Reg Deadline				October 7, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

												1		2		3				December 2, 2024										Online Testing Reg  Fees Due				October 16, 2024								FLC Fees Due																1

				4		5		6		7		8		9		10				December 10-12, 2024										Online Testing				October 19, 2024								FLC Copperas Cove HS				2		3		4		5		6		7		8						Changing the color scheme. You can change the color scheme by going to Page Layout > Themes > Colors.

				11		12		13		14		15		16		17				December 13, 2024										Online Testing Results Posted				January 6, 2025								SLC Reg  & Digital Upload Deadline				9		10		11		12		13		14		15

				18		19		20		21		22		23		24																		January 14, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				25		26		27		28		29		30		31				Area 1														January 15, 2025								SLC Fees Due				23		24		25		26		27		28								Overwriting formulas. You can overwrite a formula to place an "H" in place of a holiday for example. Be very careful if you copy/paste days so that you don't mess up the formulas. You can copy/paste the formulas for the days within the same month, but not between months.

																				October 14, 2024										FLC Reg Deadline				January 17-18,2025								Conference @ Ben Barber Innovation in Mansfield																

																				October 23, 2024										FLC Fees Due

				September 2024																October 26, 2024										FLC Round Rock ISD				Area 6												March 2025

				S		M		T		W		T		F		S				January 20, 2025										SLC Reg & Digital Upload Deadline												FLC Reg Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7				January 28, 2025										Round 2 Appointments Posted												FLC Fees Due																1

				8		9		10		11		12		13		14				January 5, 2025										SLC Fees Due												FLC Channelview HS				2		3		4		5		6		7		8						View the Print Area. To view the current print area, first view the Print Preview (Ctrl+P) then return to the Home tab. Or, go to View > Page Break Preview. The print area will become highlighted with a dashed line. To choose a new print area, select the cells you want to include and go to Page Layout > Print Area > Set Print Area.

				15		16		17		18		19		20		21				February 7-8, 2025										Conference @ Steele HS in San Antonio				January 13, 2025								SLC Reg & Digital Upload Deadline				9		10		11		12		13		14		15

				22		23		24		25		26		27		28																		January 21, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				29		30														Area 2														January 26, 2025								SLC Fees Due				23		24		25		26		27		28		29

																				September 23, 2024										FLC Reg Deadline				January 31 - February 1, 2025								Conference @ Nimitz HS in Houston				30		31										

																				October 2, 2024										FLC Fees Due

				October 2024																October 5, 2024										FLC Clear Brook HS				Area 7												April 2025

				S		M		T		W		T		F		S				January 6, 2025										SLC Reg  & Digital Upload Deadline				October 14, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

								1		2		3		4		5				January 14, 2025										Round 2 Appointments Posted				October 23, 2024								FLC Fees Due								1		2		3		4		5

				6		7		8		9		10		11		12				January 22, 2025										SLC Fees Due				October 26, 2024								FLC Academy of HS Professions La Joya		Sep		6		7		8		9		10		11		12						«  Make a list of important dates. Enter dates as text by entering an apostrophe before the date, like 'Aug 8

				13		14		15		16		17		18		19				January 24-25, 2025										Conference @ Clear Brook HS in Friendswood				January 27, 2025								SLC Reg  & Digital Upload Deadline				13		14		15		16		17		18		19

				20		21		22		23		24		25		26																		February 4, 2025								Round 2 Appointments Posted				20		21		22		23		24		25		26

				27		28		29		30		31								Area 3														February 12, 2025								SLC Fees Due				27		28		29		30						

																				October 14, 2024										FLC Reg Deadline				February 14-15, 2025								Conference @ Mary Caroll HS in Corpus Christi																

																				October 23, 2024										FLC Fees Due

				November 2024																October 26, 2024										FLC Vanguard HS				State												May 2025

				S		M		T		W		T		F		S				February 3, 2025										SLC Reg & Digital Upload Deadline				March 3, 2025								State Registration Opens				S		M		T		W		T		F		S

														1		2				February 11, 2025										Round 2 Appointments Posted				March 24, 2025								Registration & Digital Upload Deadline												1		2		3

				3		4		5		6		7		8		9				February 19, 2025										SLC Fees Due				April 1, 2025								Round 2 Appointments Posted				4		5		6		7		8		9		10

				10		11		12		13		14		15		16				February 21-22, 2025										Conference @ Tyler HS in Tyler				April 4, 2025								Fees Due				11		12		13		14		15		16		17

				17		18		19		20		21		22		23																		April 14, 2025								Early Bird Check-in				18		19		20		21		22		23		24

				24		25		26		27		28		29		30																		April 15-18, 2025						Kalahari Resorts						25		26		27		28		29		30		31

																																																										

																																		ILC

				December 2024																																						Registration Opens				June 2025

				S		M		T		W		T		F		S																										Registration & Digital Upload Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7						Online Testing																				Fees Due				1		2		3		4		5		6		7

				8		9		10		11		12		13		14						FLC-Fall Leadership Conference												June 18-21, 2025								Gaylord Hotel and Convention in Nashville, TN				8		9		10		11		12		13		14

				15		16		17		18		19		20		21						SLC-Spring Leadership Conference																								15		16		17		18		19		20		21

				22		23		24		25		26		27		28						State Leadership Conference 																								22		23		24		25		26		27		28

				29		30		31														ILC-International Leadership Conference																								29		30										
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Area 3 

October 14, 2024 FLC Reg Deadline
October 23, 2024 FLC Fees Due
October 26, 2024 FLC Vanguard HS
February 3, 2025 SLC Reg & Digital Upload Deadline
February 11, 2025 Round 2 Appointments Posted
February 19, 2025 SLC Fees Due
February 21-22, 2025 Conference @ Tyler HS in Tyler

Area 3


YearlyCalendar

		School Year Calendar Template

		https://www.vertex42.com/calendars/school-calendar.html																																																										© 2013-2018 Vertex42 LLC				INSTRUCTIONS



						Year:		2024														Beginning Month:		7																								Start day:		1		 1:Sunday, 2:Monday												«  Choose the year and beginning month

																																																																Note: If you choose Monday as the start day, you will need to modify some of the formatting in the calendars (bold vs. non-bold days).



				TEXAS HOSA



				2024-2025



				CALENDAR OF EVENTS



				July 2024																Affiliation														Area 4												January 2025

				S		M		T		W		T		F		S				November 15, 2024										Affiliation Deadline for SS				September 16, 2024								FLC Reg Deadline				S		M		T		W		T		F		S						Publishing your calendar. If you want to publish a school calendar, you must ensure that it includes the following note and URL in the footer: Calendar Templates by Vertex42.com - https://www.vertex42.com/calendars/school-calendar.html

						1		2		3		4		5		6				February 1, 2025										Affiliation Deadline for PS/MS/Collegiate				September 25, 2024								FLC Fees Due										1		2		3		4

				7		8		9		10		11		12		13																		October 26, 2024								FLC Bel Air HS				5		6		7		8		9		10		11

				14		15		16		17		18		19		20				Conference Sites														February 10, 2025								SLC Reg & Digital Upload Deadline				12		13		14		15		16		17		18

				21		22		23		24		25		26		27				September 2, 2024										Fall Conference Reg Site Open				February 18, 2025								Round 2 Appointments Posted				19		20		21		22		23		24		25

				28		29		30		31										December 16, 2024										Spring Conference Reg Site Open				February 26, 2025								SLC Fees Due				26		27		28		29		30		31								Converting the calendar to a PDF. To publish a school calendar on your website, you should first convert it to a PDF. The best way to do that is to either print to a PDF driver, or in Excel 2010/2013 you can go to Save As and select PDF.

																																		February 28 - March 1, 2025								Conference @ Socorro HS in El Paso																

																				Online Testing

				August 2024																November 11, 2024										Online Testing Reg Site Open				Area 5												February 2025

				S		M		T		W		T		F		S				November 25, 2024										Online Testing Reg Deadline				October 7, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

												1		2		3				December 2, 2024										Online Testing Reg  Fees Due				October 16, 2024								FLC Fees Due																1

				4		5		6		7		8		9		10				December 10-12, 2024										Online Testing				October 19, 2024								FLC Copperas Cove HS				2		3		4		5		6		7		8						Changing the color scheme. You can change the color scheme by going to Page Layout > Themes > Colors.

				11		12		13		14		15		16		17				December 13, 2024										Online Testing Results Posted				January 6, 2025								SLC Reg  & Digital Upload Deadline				9		10		11		12		13		14		15

				18		19		20		21		22		23		24																		January 14, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				25		26		27		28		29		30		31				Area 1														January 15, 2025								SLC Fees Due				23		24		25		26		27		28								Overwriting formulas. You can overwrite a formula to place an "H" in place of a holiday for example. Be very careful if you copy/paste days so that you don't mess up the formulas. You can copy/paste the formulas for the days within the same month, but not between months.

																				October 14, 2024										FLC Reg Deadline				January 17-18,2025								Conference @ Ben Barber Innovation in Mansfield																

																				October 23, 2024										FLC Fees Due

				September 2024																October 26, 2024										FLC Round Rock ISD				Area 6												March 2025

				S		M		T		W		T		F		S				January 20, 2025										SLC Reg & Digital Upload Deadline												FLC Reg Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7				January 28, 2025										Round 2 Appointments Posted												FLC Fees Due																1

				8		9		10		11		12		13		14				January 5, 2025										SLC Fees Due												FLC Channelview HS				2		3		4		5		6		7		8						View the Print Area. To view the current print area, first view the Print Preview (Ctrl+P) then return to the Home tab. Or, go to View > Page Break Preview. The print area will become highlighted with a dashed line. To choose a new print area, select the cells you want to include and go to Page Layout > Print Area > Set Print Area.

				15		16		17		18		19		20		21				February 7-8, 2025										Conference @ Steele HS in San Antonio				January 13, 2025								SLC Reg & Digital Upload Deadline				9		10		11		12		13		14		15

				22		23		24		25		26		27		28																		January 21, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				29		30														Area 2														January 26, 2025								SLC Fees Due				23		24		25		26		27		28		29

																				September 23, 2024										FLC Reg Deadline				January 31 - February 1, 2025								Conference @ Nimitz HS in Houston				30		31										

																				October 2, 2024										FLC Fees Due

				October 2024																October 5, 2024										FLC Clear Brook HS				Area 7												April 2025

				S		M		T		W		T		F		S				January 6, 2025										SLC Reg  & Digital Upload Deadline				October 14, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

								1		2		3		4		5				January 14, 2025										Round 2 Appointments Posted				October 23, 2024								FLC Fees Due								1		2		3		4		5

				6		7		8		9		10		11		12				January 22, 2025										SLC Fees Due				October 26, 2024								FLC Academy of HS Professions La Joya		Sep		6		7		8		9		10		11		12						«  Make a list of important dates. Enter dates as text by entering an apostrophe before the date, like 'Aug 8

				13		14		15		16		17		18		19				January 24-25, 2025										Conference @ Clear Brook HS in Friendswood				January 27, 2025								SLC Reg  & Digital Upload Deadline				13		14		15		16		17		18		19

				20		21		22		23		24		25		26																		February 4, 2025								Round 2 Appointments Posted				20		21		22		23		24		25		26

				27		28		29		30		31								Area 3														February 12, 2025								SLC Fees Due				27		28		29		30						

																				October 14, 2024										FLC Reg Deadline				February 14-15, 2025								Conference @ Mary Caroll HS in Corpus Christi																

																				October 23, 2024										FLC Fees Due

				November 2024																October 26, 2024										FLC Vanguard HS				State												May 2025

				S		M		T		W		T		F		S				February 3, 2025										SLC Reg & Digital Upload Deadline				March 3, 2025								State Registration Opens				S		M		T		W		T		F		S

														1		2				February 11, 2025										Round 2 Appointments Posted				March 24, 2025								Registration & Digital Upload Deadline												1		2		3

				3		4		5		6		7		8		9				February 19, 2025										SLC Fees Due				April 1, 2025								Round 2 Appointments Posted				4		5		6		7		8		9		10

				10		11		12		13		14		15		16				February 21-22, 2025										Conference @ Tyler HS in Tyler				April 4, 2025								Fees Due				11		12		13		14		15		16		17

				17		18		19		20		21		22		23																		April 14, 2025								Early Bird Check-in				18		19		20		21		22		23		24

				24		25		26		27		28		29		30																		April 15-18, 2025						Kalahari Resorts						25		26		27		28		29		30		31

																																																										

																																		ILC

				December 2024																																						Registration Opens				June 2025

				S		M		T		W		T		F		S																										Registration & Digital Upload Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7						Online Testing																				Fees Due				1		2		3		4		5		6		7

				8		9		10		11		12		13		14						FLC-Fall Leadership Conference												June 18-21, 2025								Gaylord Hotel and Convention in Nashville, TN				8		9		10		11		12		13		14

				15		16		17		18		19		20		21						SLC-Spring Leadership Conference																								15		16		17		18		19		20		21

				22		23		24		25		26		27		28						State Leadership Conference 																								22		23		24		25		26		27		28

				29		30		31														ILC-International Leadership Conference																								29		30										
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Area 4 

September 16, 2024 FLC Reg Deadline
September 25, 2024 FLC Fees Due
October 26, 2024 FLC Bel Air HS
February 10, 2025 SLC Reg & Digital Upload Deadline
February 18, 2025 Round 2 Appointments Posted
February 26, 2025 SLC Fees Due
February 28 - March 1, 2025 Conference @ Socorro HS in El Paso

Area 4


YearlyCalendar

		School Year Calendar Template

		https://www.vertex42.com/calendars/school-calendar.html																																																										© 2013-2018 Vertex42 LLC				INSTRUCTIONS



						Year:		2024														Beginning Month:		7																								Start day:		1		 1:Sunday, 2:Monday												«  Choose the year and beginning month

																																																																Note: If you choose Monday as the start day, you will need to modify some of the formatting in the calendars (bold vs. non-bold days).



				TEXAS HOSA



				2024-2025



				CALENDAR OF EVENTS



				July 2024																Affiliation														Area 4												January 2025

				S		M		T		W		T		F		S				November 15, 2024										Affiliation Deadline for SS				September 16, 2024								FLC Reg Deadline				S		M		T		W		T		F		S						Publishing your calendar. If you want to publish a school calendar, you must ensure that it includes the following note and URL in the footer: Calendar Templates by Vertex42.com - https://www.vertex42.com/calendars/school-calendar.html

						1		2		3		4		5		6				February 1, 2025										Affiliation Deadline for PS/MS/Collegiate				September 25, 2024								FLC Fees Due										1		2		3		4

				7		8		9		10		11		12		13																		October 26, 2024								FLC Bel Air HS				5		6		7		8		9		10		11

				14		15		16		17		18		19		20				Conference Sites														February 10, 2025								SLC Reg & Digital Upload Deadline				12		13		14		15		16		17		18

				21		22		23		24		25		26		27				September 2, 2024										Fall Conference Reg Site Open				February 18, 2025								Round 2 Appointments Posted				19		20		21		22		23		24		25

				28		29		30		31										December 16, 2024										Spring Conference Reg Site Open				February 26, 2025								SLC Fees Due				26		27		28		29		30		31								Converting the calendar to a PDF. To publish a school calendar on your website, you should first convert it to a PDF. The best way to do that is to either print to a PDF driver, or in Excel 2010/2013 you can go to Save As and select PDF.

																																		February 28 - March 1, 2025								Conference @ Socorro HS in El Paso																

																				Online Testing

				August 2024																November 11, 2024										Online Testing Reg Site Open				Area 5												February 2025

				S		M		T		W		T		F		S				November 25, 2024										Online Testing Reg Deadline				October 7, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

												1		2		3				December 2, 2024										Online Testing Reg  Fees Due				October 16, 2024								FLC Fees Due																1

				4		5		6		7		8		9		10				December 10-12, 2024										Online Testing				October 19, 2024								FLC Copperas Cove HS				2		3		4		5		6		7		8						Changing the color scheme. You can change the color scheme by going to Page Layout > Themes > Colors.

				11		12		13		14		15		16		17				December 13, 2024										Online Testing Results Posted				January 6, 2025								SLC Reg  & Digital Upload Deadline				9		10		11		12		13		14		15

				18		19		20		21		22		23		24																		January 14, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				25		26		27		28		29		30		31				Area 1														January 15, 2025								SLC Fees Due				23		24		25		26		27		28								Overwriting formulas. You can overwrite a formula to place an "H" in place of a holiday for example. Be very careful if you copy/paste days so that you don't mess up the formulas. You can copy/paste the formulas for the days within the same month, but not between months.

																				October 14, 2024										FLC Reg Deadline				January 17-18,2025								Conference @ Ben Barber Innovation in Mansfield																

																				October 23, 2024										FLC Fees Due

				September 2024																October 26, 2024										FLC Round Rock ISD				Area 6												March 2025

				S		M		T		W		T		F		S				January 20, 2025										SLC Reg & Digital Upload Deadline												FLC Reg Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7				January 28, 2025										Round 2 Appointments Posted												FLC Fees Due																1

				8		9		10		11		12		13		14				January 5, 2025										SLC Fees Due												FLC Channelview HS				2		3		4		5		6		7		8						View the Print Area. To view the current print area, first view the Print Preview (Ctrl+P) then return to the Home tab. Or, go to View > Page Break Preview. The print area will become highlighted with a dashed line. To choose a new print area, select the cells you want to include and go to Page Layout > Print Area > Set Print Area.

				15		16		17		18		19		20		21				February 7-8, 2025										Conference @ Steele HS in San Antonio				January 13, 2025								SLC Reg & Digital Upload Deadline				9		10		11		12		13		14		15

				22		23		24		25		26		27		28																		January 21, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				29		30														Area 2														January 26, 2025								SLC Fees Due				23		24		25		26		27		28		29

																				September 23, 2024										FLC Reg Deadline				January 31 - February 1, 2025								Conference @ Nimitz HS in Houston				30		31										

																				October 2, 2024										FLC Fees Due

				October 2024																October 5, 2024										FLC Clear Brook HS				Area 7												April 2025

				S		M		T		W		T		F		S				January 6, 2025										SLC Reg  & Digital Upload Deadline				October 14, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

								1		2		3		4		5				January 14, 2025										Round 2 Appointments Posted				October 23, 2024								FLC Fees Due								1		2		3		4		5

				6		7		8		9		10		11		12				January 22, 2025										SLC Fees Due				October 26, 2024								FLC Academy of HS Professions La Joya		Sep		6		7		8		9		10		11		12						«  Make a list of important dates. Enter dates as text by entering an apostrophe before the date, like 'Aug 8

				13		14		15		16		17		18		19				January 24-25, 2025										Conference @ Clear Brook HS in Friendswood				January 27, 2025								SLC Reg  & Digital Upload Deadline				13		14		15		16		17		18		19

				20		21		22		23		24		25		26																		February 4, 2025								Round 2 Appointments Posted				20		21		22		23		24		25		26

				27		28		29		30		31								Area 3														February 12, 2025								SLC Fees Due				27		28		29		30						

																				October 14, 2024										FLC Reg Deadline				February 14-15, 2025								Conference @ Mary Caroll HS in Corpus Christi																

																				October 23, 2024										FLC Fees Due

				November 2024																October 26, 2024										FLC Vanguard HS				State												May 2025

				S		M		T		W		T		F		S				February 3, 2025										SLC Reg & Digital Upload Deadline				March 3, 2025								State Registration Opens				S		M		T		W		T		F		S

														1		2				February 11, 2025										Round 2 Appointments Posted				March 24, 2025								Registration & Digital Upload Deadline												1		2		3

				3		4		5		6		7		8		9				February 19, 2025										SLC Fees Due				April 1, 2025								Round 2 Appointments Posted				4		5		6		7		8		9		10

				10		11		12		13		14		15		16				February 21-22, 2025										Conference @ Tyler HS in Tyler				April 4, 2025								Fees Due				11		12		13		14		15		16		17

				17		18		19		20		21		22		23																		April 14, 2025								Early Bird Check-in				18		19		20		21		22		23		24

				24		25		26		27		28		29		30																		April 15-18, 2025						Kalahari Resorts						25		26		27		28		29		30		31

																																																										

																																		ILC

				December 2024																																						Registration Opens				June 2025

				S		M		T		W		T		F		S																										Registration & Digital Upload Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7						Online Testing																				Fees Due				1		2		3		4		5		6		7

				8		9		10		11		12		13		14						FLC-Fall Leadership Conference												June 18-21, 2025								Gaylord Hotel and Convention in Nashville, TN				8		9		10		11		12		13		14

				15		16		17		18		19		20		21						SLC-Spring Leadership Conference																								15		16		17		18		19		20		21

				22		23		24		25		26		27		28						State Leadership Conference 																								22		23		24		25		26		27		28

				29		30		31														ILC-International Leadership Conference																								29		30										

																																																										





























































&8&K00-049Calendar Templates by Vertex42.com		&8&K00-049https://www.vertex42.com/calendars/school-calendar.html


https://www.vertex42.com/calendars/school-calendar.html

image1.png

4 Uertexyz:








Area 5 

October 7, 2024 FLC Reg Deadline
October 16, 2024 FLC Fees Due
October 19, 2024 FLC Copperas Cove HS
January 6, 2025 SLC Reg  & Digital Upload Deadline
January 14, 2025 Round 2 Appointments Posted
January 15, 2025 SLC Fees Due
January 17-18,2025 Conference @ Ben Barber Innovation in Mansfield

Area 5


YearlyCalendar

		School Year Calendar Template

		https://www.vertex42.com/calendars/school-calendar.html																																																										© 2013-2018 Vertex42 LLC				INSTRUCTIONS



						Year:		2024														Beginning Month:		7																								Start day:		1		 1:Sunday, 2:Monday												«  Choose the year and beginning month

																																																																Note: If you choose Monday as the start day, you will need to modify some of the formatting in the calendars (bold vs. non-bold days).



				TEXAS HOSA



				2024-2025



				CALENDAR OF EVENTS



				July 2024																Affiliation														Area 4												January 2025

				S		M		T		W		T		F		S				November 15, 2024										Affiliation Deadline for SS				September 16, 2024								FLC Reg Deadline				S		M		T		W		T		F		S						Publishing your calendar. If you want to publish a school calendar, you must ensure that it includes the following note and URL in the footer: Calendar Templates by Vertex42.com - https://www.vertex42.com/calendars/school-calendar.html

						1		2		3		4		5		6				February 1, 2025										Affiliation Deadline for PS/MS/Collegiate				September 25, 2024								FLC Fees Due										1		2		3		4

				7		8		9		10		11		12		13																		October 26, 2024								FLC Bel Air HS				5		6		7		8		9		10		11

				14		15		16		17		18		19		20				Conference Sites														February 10, 2025								SLC Reg & Digital Upload Deadline				12		13		14		15		16		17		18

				21		22		23		24		25		26		27				September 2, 2024										Fall Conference Reg Site Open				February 18, 2025								Round 2 Appointments Posted				19		20		21		22		23		24		25

				28		29		30		31										December 16, 2024										Spring Conference Reg Site Open				February 26, 2025								SLC Fees Due				26		27		28		29		30		31								Converting the calendar to a PDF. To publish a school calendar on your website, you should first convert it to a PDF. The best way to do that is to either print to a PDF driver, or in Excel 2010/2013 you can go to Save As and select PDF.

																																		February 28 - March 1, 2025								Conference @ Socorro HS in El Paso																

																				Online Testing

				August 2024																November 11, 2024										Online Testing Reg Site Open				Area 5												February 2025

				S		M		T		W		T		F		S				November 25, 2024										Online Testing Reg Deadline				October 7, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

												1		2		3				December 2, 2024										Online Testing Reg  Fees Due				October 16, 2024								FLC Fees Due																1

				4		5		6		7		8		9		10				December 10-12, 2024										Online Testing				October 19, 2024								FLC Copperas Cove HS				2		3		4		5		6		7		8						Changing the color scheme. You can change the color scheme by going to Page Layout > Themes > Colors.

				11		12		13		14		15		16		17				December 13, 2024										Online Testing Results Posted				January 6, 2025								SLC Reg  & Digital Upload Deadline				9		10		11		12		13		14		15

				18		19		20		21		22		23		24																		January 14, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				25		26		27		28		29		30		31				Area 1														January 15, 2025								SLC Fees Due				23		24		25		26		27		28								Overwriting formulas. You can overwrite a formula to place an "H" in place of a holiday for example. Be very careful if you copy/paste days so that you don't mess up the formulas. You can copy/paste the formulas for the days within the same month, but not between months.

																				October 14, 2024										FLC Reg Deadline				January 17-18,2025								Conference @ Ben Barber Innovation in Mansfield																

																				October 23, 2024										FLC Fees Due

				September 2024																October 26, 2024										FLC Round Rock ISD				Area 6												March 2025

				S		M		T		W		T		F		S				January 20, 2025										SLC Reg & Digital Upload Deadline												FLC Reg Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7				January 28, 2025										Round 2 Appointments Posted												FLC Fees Due																1

				8		9		10		11		12		13		14				January 5, 2025										SLC Fees Due												FLC Channelview HS				2		3		4		5		6		7		8						View the Print Area. To view the current print area, first view the Print Preview (Ctrl+P) then return to the Home tab. Or, go to View > Page Break Preview. The print area will become highlighted with a dashed line. To choose a new print area, select the cells you want to include and go to Page Layout > Print Area > Set Print Area.

				15		16		17		18		19		20		21				February 7-8, 2025										Conference @ Steele HS in San Antonio				January 13, 2025								SLC Reg & Digital Upload Deadline				9		10		11		12		13		14		15

				22		23		24		25		26		27		28																		January 21, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				29		30														Area 2														January 26, 2025								SLC Fees Due				23		24		25		26		27		28		29

																				September 23, 2024										FLC Reg Deadline				January 31 - February 1, 2025								Conference @ Nimitz HS in Houston				30		31										

																				October 2, 2024										FLC Fees Due

				October 2024																October 5, 2024										FLC Clear Brook HS				Area 7												April 2025

				S		M		T		W		T		F		S				January 6, 2025										SLC Reg  & Digital Upload Deadline				October 14, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

								1		2		3		4		5				January 14, 2025										Round 2 Appointments Posted				October 23, 2024								FLC Fees Due								1		2		3		4		5

				6		7		8		9		10		11		12				January 22, 2025										SLC Fees Due				October 26, 2024								FLC Academy of HS Professions La Joya		Sep		6		7		8		9		10		11		12						«  Make a list of important dates. Enter dates as text by entering an apostrophe before the date, like 'Aug 8

				13		14		15		16		17		18		19				January 24-25, 2025										Conference @ Clear Brook HS in Friendswood				January 27, 2025								SLC Reg  & Digital Upload Deadline				13		14		15		16		17		18		19

				20		21		22		23		24		25		26																		February 4, 2025								Round 2 Appointments Posted				20		21		22		23		24		25		26

				27		28		29		30		31								Area 3														February 12, 2025								SLC Fees Due				27		28		29		30						

																				October 14, 2024										FLC Reg Deadline				February 14-15, 2025								Conference @ Mary Caroll HS in Corpus Christi																

																				October 23, 2024										FLC Fees Due

				November 2024																October 26, 2024										FLC Vanguard HS				State												May 2025

				S		M		T		W		T		F		S				February 3, 2025										SLC Reg & Digital Upload Deadline				March 3, 2025								State Registration Opens				S		M		T		W		T		F		S

														1		2				February 11, 2025										Round 2 Appointments Posted				March 24, 2025								Registration & Digital Upload Deadline												1		2		3

				3		4		5		6		7		8		9				February 19, 2025										SLC Fees Due				April 1, 2025								Round 2 Appointments Posted				4		5		6		7		8		9		10

				10		11		12		13		14		15		16				February 21-22, 2025										Conference @ Tyler HS in Tyler				April 4, 2025								Fees Due				11		12		13		14		15		16		17

				17		18		19		20		21		22		23																		April 14, 2025								Early Bird Check-in				18		19		20		21		22		23		24

				24		25		26		27		28		29		30																		April 15-18, 2025						Kalahari Resorts						25		26		27		28		29		30		31

																																																										

																																		ILC

				December 2024																																						Registration Opens				June 2025

				S		M		T		W		T		F		S																										Registration & Digital Upload Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7						Online Testing																				Fees Due				1		2		3		4		5		6		7

				8		9		10		11		12		13		14						FLC-Fall Leadership Conference												June 18-21, 2025								Gaylord Hotel and Convention in Nashville, TN				8		9		10		11		12		13		14

				15		16		17		18		19		20		21						SLC-Spring Leadership Conference																								15		16		17		18		19		20		21

				22		23		24		25		26		27		28						State Leadership Conference 																								22		23		24		25		26		27		28

				29		30		31														ILC-International Leadership Conference																								29		30										
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Area 6 

September 16, 2024 FLC Reg Deadline
September 25, 2024 FLC Fees Due
September 28, 2024 FLC Channelview HS
January 13, 2025 SLC Reg & Digital Upload Deadline
January 21, 2025 Round 2 Appointments Posted
January 26, 2025 SLC Fees Due
January 31 - February 1, 2025 Conference @ Nimitz HS in Houston

Area 6


YearlyCalendar

		School Year Calendar Template

		https://www.vertex42.com/calendars/school-calendar.html																																																										© 2013-2018 Vertex42 LLC				INSTRUCTIONS



						Year:		2024														Beginning Month:		7																								Start day:		1		 1:Sunday, 2:Monday												«  Choose the year and beginning month

																																																																Note: If you choose Monday as the start day, you will need to modify some of the formatting in the calendars (bold vs. non-bold days).



				TEXAS HOSA



				2024-2025



				CALENDAR OF EVENTS



				July 2024																Affiliation														Area 4												January 2025

				S		M		T		W		T		F		S				November 15, 2024										Affiliation Deadline for SS				October 14, 2024								FLC Reg Deadline				S		M		T		W		T		F		S						Publishing your calendar. If you want to publish a school calendar, you must ensure that it includes the following note and URL in the footer: Calendar Templates by Vertex42.com - https://www.vertex42.com/calendars/school-calendar.html

						1		2		3		4		5		6				February 1, 2025										Affiliation Deadline for PS/MS/Collegiate				October 23, 2024								FLC Fees Due										1		2		3		4

				7		8		9		10		11		12		13																		October 26, 2024								FLC Bel Air HS				5		6		7		8		9		10		11

				14		15		16		17		18		19		20				Conference Sites														February 10, 2025								SLC Reg & Digital Upload Deadline				12		13		14		15		16		17		18

				21		22		23		24		25		26		27				September 2, 2024										Fall Conference Reg Site Open				February 18, 2025								Round 2 Appointments Posted				19		20		21		22		23		24		25

				28		29		30		31										December 16, 2024										Spring Conference Reg Site Open				February 26, 2025								SLC Fees Due				26		27		28		29		30		31								Converting the calendar to a PDF. To publish a school calendar on your website, you should first convert it to a PDF. The best way to do that is to either print to a PDF driver, or in Excel 2010/2013 you can go to Save As and select PDF.

																																		February 28 - March 1, 2025								Conference @ Socorro HS in El Paso																

																				Online Testing

				August 2024																November 11, 2024										Online Testing Reg Site Open				Area 5												February 2025

				S		M		T		W		T		F		S				November 25, 2024										Online Testing Reg Deadline				October 7, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

												1		2		3				December 2, 2024										Online Testing Reg  Fees Due				October 16, 2024								FLC Fees Due																1

				4		5		6		7		8		9		10				December 10-12, 2024										Online Testing				October 19, 2024								FLC Copperas Cove HS				2		3		4		5		6		7		8						Changing the color scheme. You can change the color scheme by going to Page Layout > Themes > Colors.

				11		12		13		14		15		16		17				December 13, 2024										Online Testing Results Posted				December 18, 2024								SLC Reg  & Digital Upload Deadline				9		10		11		12		13		14		15

				18		19		20		21		22		23		24																		January 7, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				25		26		27		28		29		30		31				Area 1														January 15, 2025								SLC Fees Due				23		24		25		26		27		28								Overwriting formulas. You can overwrite a formula to place an "H" in place of a holiday for example. Be very careful if you copy/paste days so that you don't mess up the formulas. You can copy/paste the formulas for the days within the same month, but not between months.

																				October 14, 2024										FLC Reg Deadline				January 17-18,2025								Conference @ Ben Barber Innovation in Mansfield																

																				October 23, 2024										FLC Fees Due

				September 2024																October 26, 2024										FLC Round Rock ISD				Area 6												March 2025

				S		M		T		W		T		F		S				January 20, 2025										SLC Reg & Digital Upload Deadline				September 16, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7				January 28, 2025										Round 2 Appointments Posted				September 25, 2024								FLC Fees Due																1

				8		9		10		11		12		13		14				January 5, 2025										SLC Fees Due				September 28, 2024								FLC Channelview HS				2		3		4		5		6		7		8						View the Print Area. To view the current print area, first view the Print Preview (Ctrl+P) then return to the Home tab. Or, go to View > Page Break Preview. The print area will become highlighted with a dashed line. To choose a new print area, select the cells you want to include and go to Page Layout > Print Area > Set Print Area.

				15		16		17		18		19		20		21				February 7-8, 2025										Conference @ Steele HS in San Antonio				January 13, 2025								SLC Reg & Digital Upload Deadline				9		10		11		12		13		14		15

				22		23		24		25		26		27		28																		January 21, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				29		30														Area 2														January 26, 2025								SLC Fees Due				23		24		25		26		27		28		29

																				September 23, 2024										FLC Reg Deadline				January 31 - February 1, 2025								Conference @ Nimitz HS in Houston				30		31										

																				October 2, 2024										FLC Fees Due

				October 2024																October 5, 2024										FLC Clear Brook HS				Area 7												April 2025

				S		M		T		W		T		F		S				January 6, 2025										SLC Reg  & Digital Upload Deadline				October 14, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

								1		2		3		4		5				January 14, 2025										Round 2 Appointments Posted				October 23, 2024								FLC Fees Due								1		2		3		4		5

				6		7		8		9		10		11		12				January 22, 2025										SLC Fees Due				October 26, 2024								FLC Academy of HS Professions La Joya		Sep		6		7		8		9		10		11		12						«  Make a list of important dates. Enter dates as text by entering an apostrophe before the date, like 'Aug 8

				13		14		15		16		17		18		19				January 24-25, 2025										Conference @ Clear Brook HS in Friendswood				January 27, 2025								SLC Reg  & Digital Upload Deadline				13		14		15		16		17		18		19

				20		21		22		23		24		25		26																		February 4, 2025								Round 2 Appointments Posted				20		21		22		23		24		25		26

				27		28		29		30		31								Area 3														February 12, 2025								SLC Fees Due				27		28		29		30						

																				October 14, 2024										FLC Reg Deadline				February 14-15, 2025								Conference @ Mary Caroll HS in Corpus Christi																

																				October 23, 2024										FLC Fees Due

				November 2024																October 26, 2024										FLC Vanguard HS				State												May 2025

				S		M		T		W		T		F		S				February 3, 2025										SLC Reg & Digital Upload Deadline				March 3, 2025								State Registration Opens				S		M		T		W		T		F		S

														1		2				February 11, 2025										Round 2 Appointments Posted				March 24, 2025								Registration & Digital Upload Deadline												1		2		3

				3		4		5		6		7		8		9				February 19, 2025										SLC Fees Due				April 1, 2025								Round 2 Appointments Posted				4		5		6		7		8		9		10

				10		11		12		13		14		15		16				February 21-22, 2025										Conference @ Tyler HS in Tyler				April 4, 2025								Fees Due				11		12		13		14		15		16		17

				17		18		19		20		21		22		23																		April 14, 2025								Early Bird Check-in				18		19		20		21		22		23		24

				24		25		26		27		28		29		30																		April 15-17, 2025						Kalahari Resorts						25		26		27		28		29		30		31

																																																										

																																		ILC

				December 2024																																						Registration Opens				June 2025

				S		M		T		W		T		F		S																										Registration & Digital Upload Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7						Online Testing																				Fees Due				1		2		3		4		5		6		7

				8		9		10		11		12		13		14						FLC-Fall Leadership Conference												June 18-21, 2025								Gaylord Hotel and Convention in Nashville, TN				8		9		10		11		12		13		14

				15		16		17		18		19		20		21						SLC-Spring Leadership Conference																								15		16		17		18		19		20		21

				22		23		24		25		26		27		28						State Leadership Conference 																								22		23		24		25		26		27		28

				29		30		31														ILC-International Leadership Conference																								29		30										
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Area 7 

October 14, 2024 FLC Reg Deadline
October 23, 2024 FLC Fees Due
October 26, 2024 FLC Academy of HS Professions La Joya
January 27, 2025 SLC Reg  & Digital Upload Deadline
February 4, 2025 Round 2 Appointments Posted
February 12, 2025 SLC Fees Due
February 14-15, 2025 Conference @ Mary Caroll HS in Corpus Christi

Area 7


YearlyCalendar

		School Year Calendar Template

		https://www.vertex42.com/calendars/school-calendar.html																																																										© 2013-2018 Vertex42 LLC				INSTRUCTIONS



						Year:		2024														Beginning Month:		7																								Start day:		1		 1:Sunday, 2:Monday												«  Choose the year and beginning month

																																																																Note: If you choose Monday as the start day, you will need to modify some of the formatting in the calendars (bold vs. non-bold days).



				TEXAS HOSA



				2024-2025



				CALENDAR OF EVENTS



				July 2024																Affiliation														Area 4												January 2025

				S		M		T		W		T		F		S				November 15, 2024										Affiliation Deadline for SS				September 16, 2024								FLC Reg Deadline				S		M		T		W		T		F		S						Publishing your calendar. If you want to publish a school calendar, you must ensure that it includes the following note and URL in the footer: Calendar Templates by Vertex42.com - https://www.vertex42.com/calendars/school-calendar.html

						1		2		3		4		5		6				February 1, 2025										Affiliation Deadline for PS/MS/Collegiate				September 25, 2024								FLC Fees Due										1		2		3		4

				7		8		9		10		11		12		13																		October 26, 2024								FLC Bel Air HS				5		6		7		8		9		10		11

				14		15		16		17		18		19		20				Conference Sites														February 10, 2025								SLC Reg & Digital Upload Deadline				12		13		14		15		16		17		18

				21		22		23		24		25		26		27				September 2, 2024										Fall Conference Reg Site Open				February 18, 2025								Round 2 Appointments Posted				19		20		21		22		23		24		25

				28		29		30		31										December 16, 2024										Spring Conference Reg Site Open				February 26, 2025								SLC Fees Due				26		27		28		29		30		31								Converting the calendar to a PDF. To publish a school calendar on your website, you should first convert it to a PDF. The best way to do that is to either print to a PDF driver, or in Excel 2010/2013 you can go to Save As and select PDF.

																																		February 28 - March 1, 2025								Conference @ Socorro HS in El Paso																

																				Online Testing

				August 2024																November 11, 2024										Online Testing Reg Site Open				Area 5												February 2025

				S		M		T		W		T		F		S				November 25, 2024										Online Testing Reg Deadline				October 7, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

												1		2		3				December 2, 2024										Online Testing Reg  Fees Due				October 16, 2024								FLC Fees Due																1

				4		5		6		7		8		9		10				December 10-12, 2024										Online Testing				October 19, 2024								FLC Copperas Cove HS				2		3		4		5		6		7		8						Changing the color scheme. You can change the color scheme by going to Page Layout > Themes > Colors.

				11		12		13		14		15		16		17				December 13, 2024										Online Testing Results Posted				January 6, 2025								SLC Reg  & Digital Upload Deadline				9		10		11		12		13		14		15

				18		19		20		21		22		23		24																		January 14, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				25		26		27		28		29		30		31				Area 1														January 15, 2025								SLC Fees Due				23		24		25		26		27		28								Overwriting formulas. You can overwrite a formula to place an "H" in place of a holiday for example. Be very careful if you copy/paste days so that you don't mess up the formulas. You can copy/paste the formulas for the days within the same month, but not between months.

																				October 14, 2024										FLC Reg Deadline				January 17-18,2025								Conference @ Ben Barber Innovation in Mansfield																

																				October 23, 2024										FLC Fees Due

				September 2024																October 26, 2024										FLC Round Rock ISD				Area 6												March 2025

				S		M		T		W		T		F		S				January 20, 2025										SLC Reg & Digital Upload Deadline												FLC Reg Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7				January 28, 2025										Round 2 Appointments Posted												FLC Fees Due																1

				8		9		10		11		12		13		14				January 5, 2025										SLC Fees Due												FLC Channelview HS				2		3		4		5		6		7		8						View the Print Area. To view the current print area, first view the Print Preview (Ctrl+P) then return to the Home tab. Or, go to View > Page Break Preview. The print area will become highlighted with a dashed line. To choose a new print area, select the cells you want to include and go to Page Layout > Print Area > Set Print Area.

				15		16		17		18		19		20		21				February 7-8, 2025										Conference @ Steele HS in San Antonio				January 13, 2025								SLC Reg & Digital Upload Deadline				9		10		11		12		13		14		15

				22		23		24		25		26		27		28																		January 21, 2025								Round 2 Appointments Posted				16		17		18		19		20		21		22

				29		30														Area 2														January 26, 2025								SLC Fees Due				23		24		25		26		27		28		29

																				September 23, 2024										FLC Reg Deadline				January 31 - February 1, 2025								Conference @ Nimitz HS in Houston				30		31										

																				October 2, 2024										FLC Fees Due

				October 2024																October 5, 2024										FLC Clear Brook HS				Area 7												April 2025

				S		M		T		W		T		F		S				January 6, 2025										SLC Reg  & Digital Upload Deadline				October 14, 2024								FLC Reg Deadline				S		M		T		W		T		F		S

								1		2		3		4		5				January 14, 2025										Round 2 Appointments Posted				October 23, 2024								FLC Fees Due								1		2		3		4		5

				6		7		8		9		10		11		12				January 22, 2025										SLC Fees Due				October 26, 2024								FLC Academy of HS Professions La Joya		Sep		6		7		8		9		10		11		12						«  Make a list of important dates. Enter dates as text by entering an apostrophe before the date, like 'Aug 8

				13		14		15		16		17		18		19				January 24-25, 2025										Conference @ Clear Brook HS in Friendswood				January 27, 2025								SLC Reg  & Digital Upload Deadline				13		14		15		16		17		18		19

				20		21		22		23		24		25		26																		February 4, 2025								Round 2 Appointments Posted				20		21		22		23		24		25		26

				27		28		29		30		31								Area 3														February 12, 2025								SLC Fees Due				27		28		29		30						

																				October 14, 2024										FLC Reg Deadline				February 14-15, 2025								Conference @ Mary Caroll HS in Corpus Christi																

																				October 23, 2024										FLC Fees Due

				November 2024																October 26, 2024										FLC Vanguard HS				State												May 2025

				S		M		T		W		T		F		S				February 3, 2025										SLC Reg & Digital Upload Deadline				March 3, 2025								State Registration Opens				S		M		T		W		T		F		S

														1		2				February 11, 2025										Round 2 Appointments Posted				March 24, 2025								Registration & Digital Upload Deadline												1		2		3

				3		4		5		6		7		8		9				February 19, 2025										SLC Fees Due				April 1, 2025								Round 2 Appointments Posted				4		5		6		7		8		9		10

				10		11		12		13		14		15		16				February 21-22, 2025										Conference @ Tyler HS in Tyler				April 4, 2025								Fees Due				11		12		13		14		15		16		17

				17		18		19		20		21		22		23																		April 14, 2025								Early Bird Check-in				18		19		20		21		22		23		24

				24		25		26		27		28		29		30																		April 15-18, 2025						Kalahari Resorts						25		26		27		28		29		30		31

																																																										

																																		ILC

				December 2024																																						Registration Opens				June 2025

				S		M		T		W		T		F		S																										Registration & Digital Upload Deadline				S		M		T		W		T		F		S

				1		2		3		4		5		6		7						Online Testing																				Fees Due				1		2		3		4		5		6		7

				8		9		10		11		12		13		14						FLC-Fall Leadership Conference												June 18-21, 2025								Gaylord Hotel and Convention in Nashville, TN				8		9		10		11		12		13		14

				15		16		17		18		19		20		21						SLC-Spring Leadership Conference																								15		16		17		18		19		20		21

				22		23		24		25		26		27		28						State Leadership Conference 																								22		23		24		25		26		27		28

				29		30		31														ILC-International Leadership Conference																								29		30										
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Do not overwhelm your 
proctors

Online Testing

- All students scheduled to take a particular test must do so at the same time.  
If the same test is administered at different times, all scores may be thrown 
out. 

Advisors are *not* allowed to see testing materials.

Advisor should make a schedule of tester to include date and 
time for your proctors



Special instructions will be emailed to your proctors

Online testing



Digital Uploads

No Upload required for Texas HOSA

• Clinical Specialty – No upload

• Community Awareness- No upload

• Family Medicine Physician- No upload

• Researched Persuasive Writing and Speaking- No upload



Health Career Display Health Career Photography

NEED TO UPLOAD PREJUDGING 
TO TOP 10

Health Education Interviewing Skills

Digital Uploads

Mental Health Promotion
Public HealthMRC Partnership

Research Poster

Job Seeking Skills



Thank you!
We hope you all have a wonderful ILC!

Gamification Code = LLu8mZ
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